Wing Commander - Privateer Gemini Gold

News Files Images Forum Faq Credits


posted: 12 Nov 2012, 06:00

Not to KEEP hijacking this thread but... will the current PGG shaders have to be tossed out then?

By what i'm reading it sounds like the shaders used with 1.03 (0.5 VS) cannot be used with the new VS engine release (0.5.1)?
User avatar
Posts: 84
Joined: 17 Nov 2010, 03:52

posted: 12 Nov 2012, 20:24

PGG never used its own shaders, so it should be just a matter of copying VS shaders into PGG.
User avatar
Posts: 39
Joined: 19 Apr 2006, 06:00

posted: 12 Nov 2012, 20:26

HerrKoos wrote:I solved my texture problem by the way. Turn out it wasn't a bug; I was in a system with a red sun... :D The colour and lighting behaviour of the engine takes some getting used to.

I'd consider that an "art bug". Lighting should never be fully saturated, it washes out color as you noticed. It should always contain some white.
User avatar
Posts: 39
Joined: 19 Apr 2006, 06:00

posted: 12 Nov 2012, 20:42

Thanks, I see your point. It's much less distracting now that I now what causes it.
Posts: 147
Joined: 24 Dec 2009, 08:31

posted: 02 Dec 2012, 19:00

OK, here's a weird one. I triggered it, I think, by buying a Lvl 4 engine for my Centurion off the Vega Strike screen (which in base Privateer you aren't supposed to do).

Anyway, it worked fine. Lvl 4 engine and shields made me one buttkicking merc. BUT- I did this before I took on the third Tayla mission (the "hidden compartment" run). When I accepted it and Tayla's folks installed the smuggler hold (apparently), things got strange.

1) Suddenly I had a "cargo expansion module" on my Centurion- a permanently respawning item, in other words I could sell it, step away, and there it was again, to be sold over and over again (I guess there's a lot of money to be made that way 2500 creds at a time). Even stranger, though, was that now I had an amazing cargo capacity of 350 units! This shows up on the Quine, and is reflected in the Commodity Exchange where one can indeed buy 349 units of cargo. (However, computer/guild missions will still turn you down for 'insufficient cargo space' if you're carrying over 40).

Great deal, right? Massively profitable cargo runs in a Centurion! Except it's a trap- you can spend a ton of money buying all that cargo, but when you arrive at the next base you'll find nothing but 49 items and an artifact- 300 cargo units vanished into the void.

2) But that's not the worst of it; that Magic Cargo Module I'm not supposed to have replaced something- my engine! Now neither the in-flight repair screen, the upgrade "sell" screen, nor the Vega Strike screen show it; it's gone. However, the game engine seemed not to notice- my ship still performed exactly as if it had a Lvl 4 engine installed. No problem, right? Well, not until I quit for the day and then came back- on restart, my bird had- yup - no engine at all- meaning no burner, no guns, no shield regen. Worse yet, the game's buy/sell routine seemed to think I still had an engine installed, so I couldn't buy a new one! I'm screwed!

Only fix I could figger out was to go back to an earlier save, trade in the engine for a Lvl 3 (at a massive loss) and start Tayla 3 over again. No bug- but I took a huge financial loss (and had to fight Riordan over again).

I assume this could have been fixed by editing the save file, but I have no idea how to make sense of anything beyond the first line of that gobbledygook.
Posts: 1
Joined: 27 Nov 2012, 20:01

posted: 01 Apr 2013, 17:58

Just have found funny bug...
System 'New Caledonia', if you save the game at Edinburgh and then load it you appear at Glasgow :)
Posts: 313
Joined: 29 Sep 2011, 08:02

posted: 02 Apr 2013, 00:21

It is indeed a funny bug, but reported before (2009 and 2010). Still be nice to get fixed, though. You got any ideas on the cause?
Posts: 385
Joined: 30 Jan 2007, 23:22
Location: Canada

posted: 02 Apr 2013, 06:38

well... save file stores correct coordinates, so the glitch happens when the game loads IMO. This is done by a VS.loadGame() call, seems the bug is within VS engine (system description file looks fine to me as well)
Posts: 313
Joined: 29 Sep 2011, 08:02


Return to New Detroit Com Link