Wing Commander - Privateer Gemini Gold

News Files Images Forum Faq Credits


posted: 08 Jan 2016, 01:00

I played the original (probably most of us have) way back when, and I played your remake (PGG) 5 years ago, just about to play it again.

Just wanted to say thanks for all the hours you've put into this. For whatever reason Privateer is a one of a kind game. Every "modern" space sim I play I'm really just looking for Privateer again, so I figured why not give this a shot again? Glad to see you are still updating it.
Posts: 1
Joined: 08 Jan 2016, 00:54

posted: 14 Jun 2016, 09:50

Absolutely agree! Many thanks for great work :D
Posts: 2
Joined: 14 Jun 2016, 09:14

posted: 23 Aug 2016, 20:41

Wanted to say thank you as well, I appreciate this game and your contribution a lot, in another few years, come back and add some more!
Posts: 2
Joined: 25 Jul 2013, 01:51

posted: 25 Aug 2016, 22:34

still not sure when I will be in a mood to add something more
don't have a lot of free time for gaming and currently spend it modding Civ 5 :-)
Posts: 313
Joined: 29 Sep 2011, 08:02

posted: 20 May 2017, 12:56

thank you for your help this far.
I want to report a bug in PGG, with your latest patch applied.
I'm in RF already, and try to start the (second?) task by Masterson in Oxford.
I'ts a kond of "patrol oxford" mission, internally marked as "cleansweep".
Before i take that mission, the game runs flawless (entries in stderr seem to be without consequence), after taking it, with launching, VS throws an exception, and after clicking ok, the game ends.
When i save, the game dies already while starting, only deleting the "autosave" remedies the situation.
May i send the stderr and stdout as 7z-files?
Things i tried already:
I tried to change code in the "", as this line produces an "IndexError: tuple index out of range"
>> self.obj = VS.addObjective( "Go to %s." % jumps[-1][7:])
This just made the VegaStrike Menues appear... DeadEnd... :)
Fixing the mission data in the save-file just produces another error.
After trying some more stuff, whcih just "moves" the error, it seems some bug deep inside stopps the class from correctly initializing, as in the end, there is always one or the other "var not defined" in the errorlogs.
I saw in the patrolwar-mission, that the cleansweep.cleansweep has been replaced by patrol_enemies.patrol_enemies.
I just don't understand mission-designing well enough to conduct this change on the current mission, to see, if perhaps "cleansweep" is broken, and changing the missiontype could fix it.

Any quick-fix would be well-appreciated (like, i.e., a hack that declares the mission as finished in the save-file), but to improve my python-fu, I'd also be willing to debug this, if i get enough info to find my way. ;-)
Posts: 2
Joined: 14 May 2017, 16:59

posted: 21 May 2017, 09:33

Ragnar, I've sent the fix via email.
Posts: 313
Joined: 29 Sep 2011, 08:02

posted: 21 May 2017, 19:48

... v3.02, critical bug fixed that was introduced in 3.01 and did not allow to complete the 2nd Oxford mission of the Righteous Fire addon.
Posts: 313
Joined: 29 Sep 2011, 08:02

posted: 15 Jun 2017, 08:57

I cannot fire my guns at all. Tried binding the key to other keys, but it still won't fire. I can fire my missiles but whatever keys I use for the "FireKey" just won't work.
e.g. binded "enter" to fire lasers, "space" for missiles. In the game, "enter" does not work but "space" works for missiles. After I reversed the bindings, "enter" works for missiles, "space" does not work.

Nothing I use to fire my lasers worked.

I even downloaded the original version of the game, and tried it on dosbox, and it worked after I used "g" to scroll my lasers, but it just does not work on Gemini Gold 1.03.

Changed my keyboard layout to US QWERTY, and still it does not work.
Nothing works.
I am using Windows 10 Lenovo Ideapad 100s laptop, 64-bit operating system x64-based processor.

Please help. I played this game back in the 90s, and I really do want to play it again.
Posts: 1
Joined: 15 Jun 2017, 08:39

posted: 15 Jun 2017, 09:23

Hi, do you experience this bug on a clear PGG 1.03 installation? Or just after you install my tweak pack?
Posts: 313
Joined: 29 Sep 2011, 08:02

posted: 21 Jun 2017, 05:49

Hello all!

Thanks for Podbelski's tweak, now I can start our adventures in Gemini Sector again. I'm really looking forward to try the new Orion tweaked by PGG (I was dreaming to do that when I was a teenager! 8)) . I haven't enough credits for it, yet I've checked her parameters from the UNIT.CSV file. Looks like she is a beast now! :lol:

I'm quite impressed the new missions designs.
Some problems occurs in the escort and rescue missions, due to improved AI pilots would like to use their afterburners all the time to achieve their goal. (i.e. escortee try to rush to the destination, the enemy try to intercept the ejected pilot by using their afterburner all the time.)

I'm wondering that if it is a good idea to reduce overall durations of Afterburner for all crafts, including the player's craft? Maybe there will be so much impact on the gameplay, and the Afterburner_Usage_Cost in the UNIT.CSV looks weird to me.

As far as I remember, the quasi-infinite use of Afterburner for player's crafts is quite close to original Privateer. Since the AI and the mission improved a lot, maybe it will be good to set some kind of limit on Afterburners for both AI and players?

Thanks for your great works and happy landing!
Posts: 9
Joined: 21 Jun 2017, 01:23


Return to New Detroit Com Link